KB3: Hiss/Fuzz from ONLY One Input

This forum is for talking about Peavey keyboard amplifiers.
Post Reply
saberkiwi
New Member
Posts: 2
Joined: Mon Apr 15, 2019 7:55 pm

KB3: Hiss/Fuzz from ONLY One Input

Post by saberkiwi » Mon Apr 15, 2019 7:58 pm

I have a Peavey KB3 that produces a "shhhhh" to "SKWOSHHHHHHH" depending on Channel 1 (1/4") volume, with no audio devices plugged into it at all. I've tightened the nuts at the end of the jacks to verify snug connection, and opened up the amp to see if there's anything immediately visible. Nada. Then again, I have no idea what I'm looking for.

If I turn Channel 1 all the way down, I can use the remaining inputs as normal, no hiss. I'm a noob at amp innards; any advice greatly appreciated.

- S.

User avatar
Enzo
Member
Posts: 9122
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: KB3: Hiss/Fuzz from ONLY One Input

Post by Enzo » Tue Apr 16, 2019 2:46 pm

Bad channel 1 op amp, broken solder connection, open cap.

saberkiwi
New Member
Posts: 2
Joined: Mon Apr 15, 2019 7:55 pm

Re: KB3: Hiss/Fuzz from ONLY One Input

Post by saberkiwi » Thu Apr 18, 2019 5:35 pm

Enzo wrote:
Tue Apr 16, 2019 2:46 pm
Bad channel 1 op amp, broken solder connection, open cap.
How do you get to where the solder connection actually is? What is an open cap? ...Any recommendations on where I can learn more about learning all this? :)

User avatar
Enzo
Member
Posts: 9122
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: KB3: Hiss/Fuzz from ONLY One Input

Post by Enzo » Fri Apr 19, 2019 2:12 pm

The solder is on the underside of the board, so board has to come out.

A cap is a capacitor, and open means not functioning, like an open fuse or open light bulb.

There are many basic electronics tutorials online.

Post Reply