Impulse100 750WPeak

This forum is for discussions on all kinds of Peavey speakers and enclosures.
Post Reply
acaine
New Member
Posts: 3
Joined: Thu Nov 05, 2020 9:35 am

Impulse100 750WPeak

Post by acaine » Thu Sep 09, 2021 9:16 am

Have 2 Impulse100 I think 15" the sound barley comes out of them, any idea on cost to repair? ball park

I am thinking of replacing them with the PR15 would that be the same the specs look similar

I have a XR8600 powering them..

Thx

User avatar
Enzo
Member
Posts: 9223
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: Impulse100 750WPeak

Post by Enzo » Thu Sep 09, 2021 10:46 pm

How long is a piece of string?

Did you connect the speakers to some other amp as a test? And have you tried your amp with other speakers? We want to be sure th speaker is the problem or not.


Cost of repair very much depends upon what we actually wind up fixing.

acaine
New Member
Posts: 3
Joined: Thu Nov 05, 2020 9:35 am

Re: Impulse100 750WPeak

Post by acaine » Fri Sep 10, 2021 7:57 am

We only have one amp, the two speakers on the Right side work perfectly, I plugged the speaker into those jacks and the same results little to no sound. I just picked up a pair of 15" PR15 and will take the Impulse100 and see how to much to get them repaired.

If I get the 100's fixed what mixer can I buy to run those two speakers. We have an XR8600 for the 4 speakers in our arena. I can get away with the PVI line of mixers?

Stryker57
Member
Posts: 926
Joined: Fri Aug 20, 2010 9:39 am
Location: Cincinnati,Ohio

Re: Impulse100 750WPeak

Post by Stryker57 » Tue Sep 14, 2021 8:22 pm

chances are low but....
did you use the same cable that was on the dead speaker and just switch the connection at the amp
or did you drag the speaker over to the other one and use the 100% guaranteed working cable out of the good speaker?

might have a shorted cable it happens .

Post Reply