XPort on Mac OSX Yosemite

Powered by the USB bus and featuring both Headphone and Line outputs, the Xport provides musicians with a simple, hassle-free digital recording solution.

Moderator: AmpKit Support

Post Reply
snowtape
New Member
Posts: 2
Joined: Tue Dec 09, 2014 2:12 pm

XPort on Mac OSX Yosemite

Post by snowtape » Tue Dec 09, 2014 2:20 pm

Hello,
I've just updated my OS to Yosemite. Since the update, my computer doesn't seem to get a signal from the xport audio-interface anymore. Although it is recognised. I've tried it on a Windows PC too and there didn't seem to be any problems, so the interface or cable isn't broken. I also tried to download and install the current driver once again and restarted the computer but the problem remains. Have you any experiences with the Xport on Yosemite?
I'm glad about any advice you can give.

GuyWithGuitars
New Member
Posts: 1
Joined: Wed Dec 10, 2014 6:10 pm

Re: XPort on Mac OSX Yosemite

Post by GuyWithGuitars » Wed Dec 10, 2014 6:16 pm

Unfortunately, like me, YOU are totally S.O.L. using the XPort if you've upgraded to OSX Yosemite.

Spent hours trying to get it to work. Finally crushed it with a hammer (the XPort, not my MBP) and threw it out.

The XPort -did- work in Mavericks (10.9) but it still took some coercing. In Yosemite, it is dead as the proverbial doornail.

I emailed Peavey some time ago about upgrading the drivers but never heard back from them and don't anticipate hearing back either. They have more important things no doubt than to fiddle with an old, probably soon to be discontinued product. I did like my XPort. Simple and quiet when direct recording bass guitar.

This, admittedly is more of a Mac thing though. I thought I thoroughly checked compatibility before upgrading to 10.10, but totally forgot about my Peavey XPort.

Whizz1976
New Member
Posts: 2
Joined: Sat Dec 13, 2014 6:41 am

Re: XPort on Mac OSX Yosemite

Post by Whizz1976 » Sat Dec 13, 2014 6:48 am

Hi,

I've had the same problem, and have only just had the time to find the solution. :D

I think the selection of the input from the Peavey USB is messed up by some setting either within Yosemite/Peavey. Anyway to the solution. If you go to the MIDI settings (I know it is counter-intuitive, it's not MIDI but hang on in there with me), select the Peavey on the left hand side, then for the input option select External Line Connector (as the screengrab shows). This worked for me!

I was flummoxed as the sound was going out of the headphones / line out - meaning the drive should be ok, but not taking the guitar input into Pro Logic - despite everything to contrary being set do it did! :-/

Works for me, hope it works for you :-)

Cheers,
StuImage

Whizz1976
New Member
Posts: 2
Joined: Sat Dec 13, 2014 6:41 am

Re: XPort on Mac OSX Yosemite

Post by Whizz1976 » Sun Dec 14, 2014 1:06 pm

Hi,

I had the same problem, if you goto MIDI settings in Utils, and select the Xport, for inputs select external line collector, that solved it for me.

Cheers,
Stu

snowtape
New Member
Posts: 2
Joined: Tue Dec 09, 2014 2:12 pm

Re: XPort on Mac OSX Yosemite

Post by snowtape » Sat Jan 03, 2015 10:04 am

Hi,
only just found time to try it and it really worked! Thanks a lot.
Cheers

scooterhax
New Member
Posts: 1
Joined: Sat Jan 31, 2015 1:18 pm

Re: XPort on Mac OSX Yosemite

Post by scooterhax » Sat Jan 31, 2015 1:24 pm

hi new to peavy been using on my mac for a week ,decided to update to yosemite.
Know can't get it to work with garage band .
i looked at the answers and tried to make it work ,with no luck..
do theses answers work for everyone or is it me doing it wrong .
can some be so kind as to walk me through it in easy steps ,only had mac a week .so new to system .
thank you to all who can help
kind regards scooter

jandrole
New Member
Posts: 1
Joined: Sat Jun 11, 2016 12:23 pm

Re: XPort on Mac OSX Yosemite

Post by jandrole » Sat Jun 11, 2016 12:52 pm

Hello, I have bought an xport and I have a problem, my Macbook Pro doesn´t recognize the Peavey Xport input USB port. That recognizes the output Peavey Xport USB port, but it doesn´t let me to develope the Macbook Pro audio. I have installed the latest driver from the Peavey.com site.

The characteristics of my Macbook Pro are:Macbook Pro (13-inch, Late 2011)Processor 2.4 GHz Intel Core i51333Mz 16GB DDR3 MemoryGraphics Intel HD Graphics 3000 512MBOS X YosemiteAny solution?. Thank you

fanibacsi
New Member
Posts: 1
Joined: Wed Sep 30, 2020 8:55 am

Re: XPort on Mac OSX Yosemite

Post by fanibacsi » Wed Sep 30, 2020 9:02 am

snowtape wrote:
Sat Jan 03, 2015 10:04 am
Hi,
only just found time to try it and it really worked! Thanks a lot.
Cheers
hey there. i have a same problem with catalina. i try what you say, but not realy understand. i go to preferences. than midi. than left side try to found xport, but there is nothing like xport. many different midi controller type, but not xport. how and where can i select that? em i missunderstood something? please help.

thanks a lot

Post Reply