No Sound from 3rd Party plugins?

ReValver HP, MkIII, and MkIII.V Product Support.

Moderators: Michael Ljunggren, ReValver Support Team

Post Reply
singermustdie
New Member
Posts: 2
Joined: Sat Sep 28, 2019 2:48 pm

No Sound from 3rd Party plugins?

Post by singermustdie » Tue Oct 01, 2019 10:50 pm

I can't get any sounds from the 3rd party plugin racks. All other Rev-native functions work, but no plugins.

Is there a specific chain that I have to follow?

I'm on a mac using au

User avatar
Cristofe
Member
Posts: 203
Joined: Sun Feb 02, 2003 7:26 am
Location: Auburn, NY USA
Contact:

Re: No Sound from 3rd Party plugins?

Post by Cristofe » Tue Oct 08, 2019 6:07 pm

Get a pc Apple fanbois. Apple has been throwing pro audio/multimedia users further under the bus with every new
OS release. They are more concerned with your Mac playing nice with your iPhone. Catalina has broken EVERYTHING.
I got scores of e-mails from plugin developers saying NOT to upgrade. Sorry your precious Mac no longer "just works".
Play accordion....get beheaded....it's sharia law

https://soundcloud.com/cristofe-chabot

User avatar
Cristofe
Member
Posts: 203
Joined: Sun Feb 02, 2003 7:26 am
Location: Auburn, NY USA
Contact:

Re: No Sound from 3rd Party plugins?

Post by Cristofe » Wed Oct 09, 2019 1:15 pm

Just FYI......

As far back at June 17th 2019, just 2 weeks after Apple announced macOS Catalina, Presonus published this warning on their website…

“Apple’s latest upcoming Operating System Mac OSX 10.15 (Catalina) has started its Public Beta Phase. As Apple's Public Beta progresses, changes will be made to their Beta builds along the way.

Should you be part of Apple's open public Beta, the versions shared to the public (prior to the actual commercial release) do not fully reflect the final version that is actually approved for commercial usage.

Until such time as PreSonus has fully reviewed its products after Apple has officially released the commercial version of OSX 10.15, compatibility and usage of OSX 10.15 Beta Version is at your own risk and PreSonus Support will defer you to Apple's Beta Program for further information.”

Native Instruments
On September 10th 2019 Native Instruments posted …

“Native Instruments software and hardware products are not supported under macOS 10.15. Please do not install macOS 10.15 if you are using Native Instruments products.

We are currently conducting systematic tests to offer full compatibility as soon as possible after the official release. Please check this page or your Native Instruments product's specifications page regularly to obtain information on the current operating system requirements.”

Audient
One day later on September 11th, 2019 Audient posted this on their Facebook page…

“IMPORTANT NEWS FOR MAC USERS. Right now, macOS Catalina (10.15) is not supported by Audient. Therefore we recommend that our users do not upgrade to macOS Catalina until further notice. We're currently working on it, and will let you know of any changes”.

Blue Cat Audio
On September 16th 2019, posted this simple message on their Facebook page…

“This time of the year again... Checking compatibility with Apple's upcoming version of Mac OS!”

Although not an explicit ‘do not upgrade’ statement, it is clear that they are just starting the checking and testing process with macOS Catalina. Then on September 30th 2019, Blue Cat Audio posted this on their Dark Side Of The Cat blog…

“Every year, new Mac OS releases come with compatibility issues, and Catalina will probably be much worse, given the drastic changes:

No more 32-bit applications: if you are still using 32-bit apps and plug-ins, with Catalina you can forget about it. It will just not load 32-bit only plug-ins or applications.

Hardened security: Mac OS 10.15 comes with new security rules that will impact pro audio applications quite a bit, and plug-ins even more. Expect random crashes or error messages that will specific to every single host application.

So it is definitely worth waiting before you upgrade. And if you do upgrade, you should keep an older version of your system if you want to be able to work in the coming weeks: external hard drives are your friends!”

But Wait There Are More…
Ableton
They have updated their MacOS Compatibility with Live knowledgebase article with…

“Live 10 is not officially compatible with Catalina. However we are currently testing a Catalina-compliant version of Live 10 on Centercode (our beta software platform).

Live 9 is not compatible with Catalina as it contains certain components which are no longer supported on macOS 10.15. The last officially supported version of macOS with Live 9 is macOS 10.13 (High Sierra). See our dedicated article: Live 9 is not compatible with macOS 10.15 Catalina.”

Acustica Audio
Acustica Audio has posted this warning on the Support pages of their website…

“We are analysing the situation and currently conducting tests to offer full compatibility as soon as possible. However, we strongly advise you do NOT update to macOS Catalina to avoid compatibility issues and/or loss of data.”

AIR Music Tech
AIR Music Tech has posted an announcement on their Facebook page saying…

"IMPORTANT - macOS Catalina is likely to be released in the near future.

We'll aim to finalise testing and confirm compatibility ASAP, but for now, we strongly recommend waiting if you rely on your setup for professional use.

While your AIR Music Tech products may be supported at launch we strongly recommend checking with the developers of your chosen DAW's, Plugins and other products to ensure they also support this os prior to updating as all components will need to be supported for correct operation.

Once information is available we will update our website.”

Akai Professional
Akai has posted the following on their Facebook page...

"IMPORTANT - macOS Catalina is likely to be released in the near future. We'll aim to finalise testing and confirm compatibility ASAP, but for now, we strongly recommend waiting if you rely on your equipment for professional use. While your Akai Professional products may be supported at launch we strongly recommend checking with the developers of your chosen DAW's, Plugins and other products to ensure they also support this os prior to updating. Once information is available we will update our website.”

Antares
Antares has posted this announcement on their website...

"Antares products are currently not supported for use with macOS 10.15 Catalina. At this time we recommend that Antares users do not upgrade to Catalina until we've verified that our products are fully compatible. If your Mac is set to automatically update, please go to System Preferences -> Software Update and uncheck the box labelled ‘Automatically keep my Mac up to date.’ This page will be updated with more information, as we continue to work towards full compatibility with the new macOS.”

Arturia
Arturia has posted this announcement on their website...

"Our virtual instruments and effects are not yet compatible with macOS 10.15 Catalina. To keep working in safe and trouble-free conditions, we strongly advise waiting before updating your OS. Thank you in advance for your understanding. The Arturia team."

Avid
Avid has posted a Knowledge Base Article and emailed their users saying…

“Hello,

In October, Apple will release a new operating system, macOS 10.15 Catalina.

To ensure your Avid creative products work the way they should, we recommend waiting to update until we have confirmed compatibility. We’re working closely with Apple to ensure our software is compatible with macOS 10.15. In the meantime check here for more information regarding your Avid products and support for macOS Catalina.

Thank you,

The Avid Team”

Boss
Boss has posted this announcement on their website…

“If you are using a Roland product via a USB connection to a Mac computer, please refrain from upgrading to macOS Catalina (macOS 10.15), which is about to be newly released. Compatibility with macOS Catalina (macOS 10.15) will be verified and announced after the release of macOS Catalina (macOS 10.15). They also list a range of products that they expect not to work with Catalina.”

Denon DJ
Denon DJ has posted this warning on their Denon DJ Forum…

“Mac users: Denon DJ products and accompanying software are not yet compatible with macOS Catalina. Due to this incompatibility, we ask all customers to wait until we announce official support before upgrading to macOS 10.15. We will inform you when it is safe to upgrade.”

Eventide

Eventide has emailed this statement to their users...

"Apple expected to release macOS Catalina in October. Eventide plugins are currently not supported under macOS 10.15. We are conducting systematic tests and there are several known issues that we are working on resolving. Please do not install macOS 10.15 if you are using Eventide plugins. Visit our Catalina Forum thread regularly to obtain up-to-date information on macOS 10.15 support.”

FabFilter
FabFilter has posted this on their User Forum…

“macOS Catalina is still in a beta phase, so we're waiting on the official release. Of course, we will make our plug-ins compatible with Catalina when it is time!”

FXpansion
FXpansion has posted this warning on their User Forum…

“Given the upcoming release of macOS 10.15 Catalina, we’ve been performing in-house testing to establish the compatibility of our existing software with this macOS update. Testing so far has revealed that changes introduced in macOS 10.15 may affect the compatibility of FXpansion software. We recommend that you wait to update to macOS 10.15 Catalina until we’ve ensured compatibility, and given the all-clear that you’re safe to update. We’ll let you know once we’ve ensured that all existing products are no longer affected and that it's safe to update. We'd like to apologise for any inconvenience this may cause, and thank you for your understanding and co-operation.”

Icon Pro Audio
Icon ProAudio has posted this warning on the Latest News section of their website…

“The next version of macOS (10.15 Catalina) is due to release this month. Apple has made several changes in this new Operating System version that may affect the performance of many manufacturers’ applications and hardware devices. This is also true of iCON Pro Audio products. We are working diligently to ensure full compatibility with macOS Catalina, but at the moment, WE RECOMMEND THAT YOU WAIT BEFORE UPGRADING YOUR MAC TO macOS CATALINA.

If you have iCON software installed or are using an iCON plug and play hardware device on a Mac, we strongly suggest that you do not upgrade your Mac to OS 10.15 Catalina at this time.

iCon Pro Audio Software products affected include all iMap and ProDriveIII applications. Hardware devices affected are all iCON audio interfaces, control surfaces, keyboards and pad controllers.

We want to make sure that you will have the best experience possible when using our products, so we are working right now, and taking the time needed to get this right. Once we have achieved full support with Mac OS 10.15 Catalina, we would like to let you know.”

iZotope
iZotope have posted this on their website...

"We recommend that iZotope users continue to remain on current macOS versions until further notice as iZotope Products are not yet qualified for use in macOS Catalina (Version 10.15). More information will be available following the release of the new macOS. Please check back here for updates."

Korg
Korg has posted this announcement on their news section of their website…

“Dear KORG users, We are excited about macOS Catalina and iOS13 from Apple Inc. and we are currently testing all KORG products to be compliant for these OS and will confirm compliance dates for each KORG product as soon as possible. Now, some products do not work with these OS. Until we have confirmed compliance, we advise waiting until all devices and applications have been tested before updating to these OS.”

Kuassa
Kuassa has posted this warning on KVR...

"A Warning Before You Upgrade Mac OS Catalina. Apple will release its new operating system update for macOS 10.15 (Codename Catalina) next week. To ensure your Kuassa products work the way they should, we strongly recommend waiting before you update. Historically, previous Mac OS updates may contain changes in how file location management works, thus might cause many software (not only our products) to not working as they should. We are working to ensure that our products are fully compatible with macOS 10.15. So please wait until further notice."

Numark
Numark has posted this warning on their Twitter Feed…

“STOP!! Mac users: Numark products and accompanying software are not yet compatible with macOS Catalina. Due to this incompatibility, we ask all customers to WAIT until we announce official support before upgrading to macOS 10.15. We will inform you when it is safe to upgrade.”

Pioneer DJ
Pioneer DJ has posted this announcement on their User Forum…

“Please refrain from using macOS Catalina 10.15 beta. It has been reported that our driver software for some controllers can’t be installed on Apple Inc.’s operating system macOS Catalina 10.15 beta. We will investigate the compatibility of the official version of macOS Catalina 10.15 with rekordbox and our hardware. Please note that we do not guarantee the operation of rekordbox and hardware products in the beta version of macOS Catalina 10.15.”

Plugin Alliance
Plugin Alliance has posted this warning in the Support section of their website.

“As many of you may know Apple most likely releases their new OS Catalina the end of September. We are currently doing testing to make sure that Calatlina will be compatible with all of our plugins. We are actively doing this as fast as we can.

To avoid any disruption with work you may have ongoing, it is highly suggested by our technicians that you do not update to Catalina until we announce that everything is functioning as it should. Therefore you would avoid having to roll back to your previous OS.

We will announce the compatibility through our site and Newsletter”

Positive Grid
Positive Grid has posted this warning in their Help Center…

“As you may already know, Apple will soon release macOS Catalina (10.15) sometime in October.

To ensure that all your Positive Grid products work the way they should, we strongly urge you to put upgrading to macOS Catalina on hold for the time being.

It is our goal to add macOS Catalina to our list of compatible operating systems for all our products. In the meantime, please remain with your current macOS version until an official announcement has been made.

Further updates will be provided here when available.”

Rob Papen
Rob Papen has posted this on their Facebook page...

"Mac users with Rob Papen software. Please don't upgrade to OSX-10.15 Catalina. Our software is not yet compatible with this new OS from Apple"

Rogue Amoeba
Rogue Amoeba has posted this announcement on the Status page of their website…

“We're working on updates to all of our software for Apple's forthcoming MacOS 10.15 (Catalina) update. Several updates are already available, so if you're using Catalina, be sure to check the table below to see which of our software will run on it. We still urge our customers to stick with a fully supported version of MacOS for the time being.”

They then have a list of the provisional supported status of their software products.

Roland
Roland has posted this announcement on their website…

“If you are using a Roland product via a USB connection to a Mac computer, please refrain from upgrading to macOS Catalina (macOS 10.15), which is about to be newly released.

Compatibility with macOS Catalina (macOS 10.15) will be verified and announced after the release of macOS Catalina (macOS 10.15).

The following applications that Roland provides might possibly fail to work under macOS Catalina (macOS 10.15).

If you're currently using any of the applications below, please refrain from upgrading to macOS Catalina (macOS 10.15).

With regard to the operation of the respective applications and any future response, we will conduct verification after macOS Catalina (macOS 10.15) is released, and announce our findings here.”

ROLI
ROLI has posted this announcement in the Support section of their website…

“Given the upcoming release of macOS 10.15 Catalina, we’ve been performing in-house testing to establish the compatibility of our existing software with this macOS update.

Testing so far has revealed that changes introduced in macOS 10.15 may affect the compatibility of ROLI software. We recommend that you wait to update to macOS 10.15 Catalina until we’ve ensured compatibility, and given the all-clear that you’re safe to update.

We’ll let you know once we’ve ensured that all existing products are no longer affected and that it's safe to update.

We'd like to apologise for any inconvenience this may cause, and thank you for your understanding and co-operation.”

Serato
Serato has made a number of announcements about their range of products.

For Pitch 'n Time Pro, Pitch 'n Time LE, Sample, Studio, DJ Pro and DJ Lite the message is the same…

“macOS 10.15 Catalina is currently in BETA, but is not yet supported for use”

However, a number of their products will be affected by Apple’s change from iTunes to Apple Music which will happen when macOS Catalina is launched. Serato has posted this announcement regarding Apple Music…

“We are currently looking into our iTunes integration with the developer BETA of macOS 10.15 Catalina. We will continue to update users as we know more.”

Slate Digital
Slate Digital has posted this on their Support Forum…

“With the upcoming release of macOS Catalina, we urge all of our customers to wait before updating. We are currently in the process of running tests to offer compatibility after the official release and should have more information available in the near future. Please reference this page in regards to Catalina compatibility or reach out to support for the latest news.”

Solid State Logic
Its a mixed bag with SSL regarding macOS Catalina support. This is what they have currently posted in their Help Centre…

"The V6 release of SSL Native plug-ins is compatible with Mac OS Catalina.

Nucleus2 Dante Soundcard - Compatibility is dependent on Dante Controller and Dante Virtual Soundcard software by Audinate.

Nucleus2, Matrix2, AWS, Duality - NOT COMPATIBLE – SSL Remote programs for these products are currently 32 bit and will not work with Catalina. Please refrain from updating your system until further notice.

Remote/ipMIDI/Delta control functionality - You must be running ipMIDI V1.7 for compatibility with Mac OS Catalina. This is available from the downloads section in the My Products page in your SSL account, your console will still connect with the same settings as before.

The latest versions of Delta Control plugins are compatible with Mac OS Catalina.

V2.1/33 of the Sigma Remote application is compatible with Mac OS Catalina.

Sigma – NOT COMPATIBLE - While it would seem that the Sigma Remote application does work in Catalina the Sigma itself is not recognised as a network device and currently will not communicate with Catalina. You can use the Sigma if you are connected to a network switch.

Compatibility for Delta Link depends on Pro Tools hardware and software and not the operating system. Please note that for Pro Tools HD 12.6 or higher, you will require a DigiLink I/O iLok license and the latest V2.00 Delta Link firmware."

Sound Radix
On October 8th 2019, Sound Radix posted this updated statement on their Facebook page…

“IMPORTANT: 32 LIVES Users :

As you may already know, Apple has dropped support for 32-bit applications and plug-ins in Catalina; therefore, 32 Lives is not compatible with macOS Catalina. However, we will continue to sell it for those using earlier macOS versions. If you wish to continue using 32 Lives please continue to use macOS Mojave or earlier OS versions.

Sound Radix And macOS Catalina :

We are working with Apple to complete test our plug-ins for use with macOS Catalina. Once testing is complete and we know there will be no disruption to your creative workflow, we will notify all our radical users. Until then, please continue to use macOS Mojave or earlier.”

Soundtoys
Soundtoys have emailed their users saying…

Apple is expected to release macOS 10.15 Catalina in October.

We strongly recommend waiting to upgrade to this OS until we've had a chance to fully qualify our software with this release and issue any necessary updates, which we will do as soon as possible.

Sounds In Sync
All the apps from Sounds In Sync like EdiLoad, EdiPrompt etc. are 32-bit apps and currently will not work in macOS Catalina. Sounds In Sync is working on 64-bit versions of all their apps and have released their first 64-bit app EdiCue V3.

Steinberg
In response to a question in their User Forum about Dorico, Daniel from Steinberg posted this...

"I would not recommend using Dorico with beta versions of macOS (or indeed with "Insider" versions of Windows). With particular regard to macOS 10.15 Catalina, there are further new security features in the operating system this year that could conceivably cause problems with the inter-process communication that Dorico relies upon for licensing and the audio engine. Until the various teams within Steinberg have been able to test our products properly against the new operating system, I would suggest staying clear of the new operating system if the correct operation of your software is important to you. We will provide detailed compatibility information for macOS 10.15 Catalina when it is released, but not before."

Universal Audio
Universal Audio have emailed this statement and posted an article on their website…

“As you may know, Apple released macOS 10.15 Catalina today.

Please note — UAD and UA Audio Interface software cannot be installed on macOS Catalina.

We recommend that you wait until UAD software compatibility with Catalina is announced before updating to this new operating system.

Important: To prevent macOS from updating automatically, uncheck the “Install macOS updates” option in System Preferences > Software Update > Advanced options.

UAD compatibility with Catalina is being tested now and complete Catalina qualification will be released in a future UAD software update. For more information and the latest Catalina news, please read the article posted in our Knowledge Base.”

Waves
Waves have sent the following in an email to all their users…

“During October, Apple will release a new operating system, macOS 10.15 Catalina.

We are working closely with Apple to ensure that our software is compatible and that your Waves plugins and applications will work properly.

However, until we confirm full compatibility, we strongly recommend you remain on your current version of macOS.

In the meantime, please note:

Waves plugins v10 will open in macOS 10.15 Catalina but are not officially supported.

Waves’ eMotion LV1 mixer v10 will open in macOS 10.15 Catalina but is not officially supported.

Other Waves applications (MultiRack, StudioRack, SoundGrid Studio) are not supported and will not open in macOS 10.15 Catalina.
We will update you very soon about macOS 10.15 Catalina compatibility developments.”
Play accordion....get beheaded....it's sharia law

https://soundcloud.com/cristofe-chabot

Post Reply