SP 4P speakers

This forum is for discussions on all kinds of Peavey speakers and enclosures.
Post Reply
chillyq
New Member
Posts: 2
Joined: Wed Jul 10, 2019 7:39 am

SP 4P speakers

Post by chillyq » Wed Jul 10, 2019 7:53 am

I just purchased these SP 4P speakers about a week ago. One of the horns keeps blowing the driver at real low volume, the speaker should be under warranty. But, does anyone have an idea what the cause is. I went back to the dealer where I bought them and they gave me a new driver. As soon as I turned it on with volume at zero, I turned the volume to about level 2 them the new driver blew. I took a spare speaker that I had just to see if there was power at the wires and the speaker worked....any assistance please

grindboy5150
Member
Posts: 45
Joined: Fri Jun 07, 2013 1:27 am

Re: SP 4P speakers

Post by grindboy5150 » Wed Jul 10, 2019 9:58 pm

What does the dealer say? Perhaps since they are local, you can take your setup to them and they could help to determine the cause.

Dookie
Member
Posts: 841
Joined: Fri Oct 10, 2008 5:09 pm
Location: Maine USA

Re: SP 4P speakers

Post by Dookie » Fri Jul 12, 2019 6:43 pm

It almost sounds like the horn is being driven by the wires designed to go to the woofers. I know in the old days the wires that always fed the horns was Red and Black. Take a look at the wires feeding the horn and see what colors they are. Maybe even compare the 2 boxes and see if they are the same. If not than it could be a problem with the power amp section and the entire speaker needs to go back to Peavey or your dealer should replace it with a entirely new speaker.

Did you purchase just the 1 speaker? The Volume knob on the back has no relation to how loud the speaker can go. It just determines how much "Input" is needed before the speaker reaches full volume. When your running the speaker did you look on the back and see if the DDT light was coming on? If it was then your at the max output and need to turn the mixer down so this is not coming on.

Doug

chillyq
New Member
Posts: 2
Joined: Wed Jul 10, 2019 7:39 am

Re: SP 4P speakers

Post by chillyq » Tue Jul 16, 2019 10:36 am

Yes, I purchased two speakers the other one is fine. I took the speaker back to the dealer and tested the speaker. They said that the amp for the horn is clipping so they sent it back to Peavey for an exchange. Both speakers were brand new other than what was played in the showroom. I didn’t even get a chance to really test them out at a gig yet.But, thx for the feedback.

Post Reply