Vypyr 75 Firmware update?

A forum for discussing the Vypyr series amplifiers, Sanpera footswitches and share settings
Post Reply
Roleki
New Member
Posts: 1
Joined: Mon Jun 24, 2019 7:02 pm

Vypyr 75 Firmware update?

Post by Roleki » Mon Jun 24, 2019 7:27 pm

Love my gen 1 Vypyr 75 but it's never worked well at all w/ my Sanpea 1 pedal (connects 10% of the time & even then sporadically) Anyone think a firmware update will help (it's currently 1.5.8)? Amp works great otherwise. Found a vypyr firmware history that lists 1.6.6 but Peavey's psge only goes up to 1.5.9

dalrymple
Member
Posts: 2739
Joined: Mon Sep 15, 2008 8:12 pm

Re: Vypyr 75 Firmware update?

Post by dalrymple » Tue Jun 25, 2019 7:00 pm

Dont do it. Your sanpera problem is more likely the dang multi pin plug, not firmware. It is annoying when the pedal is not functioning. Buy a new cable. Most likely culprit. I've gone through 5 of them in a decade. They get hinky.

Firmware swaps in Vypyrs can leave the amp dead. Dont do it. If it works in every other way, DO NOT UPDATE THE FIRMWARE. You will not solve the pedal issue and could kill the amp.
Dalrymple

User avatar
JamesPaul
Member
Posts: 2208
Joined: Fri Sep 12, 2008 7:28 pm
Location: Hometown of THE GODZ & ROSIE

Re: Vypyr 75 Firmware update?

Post by JamesPaul » Tue Jun 25, 2019 9:59 pm

Try some Deoxit on the cable, and plug and unplug a few times, both ends. I own a 75 that went thru all the firmware updates and even a back level or two. It has been rock solid thru all all. But as Dalrymple notes, others have not been as successful. There are some solid recommendations on firmware level in the Tips/Tracks/FAQs topic.
Enzo wrote:I find if the amp is working, that is a good point to stop fixing it.
James Paul's Peaveys
Decade, Classics, Ecoustic, Windsors, VYPYR, Triple XXX, XXL, VKs, Bandit, JSXs, VIP, Piranha and a Penta.

Kris0725
New Member
Posts: 2
Joined: Sat May 30, 2020 5:26 am

Re: Vypyr 75 Firmware update?

Post by Kris0725 » Thu Jun 04, 2020 12:06 am

I have bin firmware.

Post Reply