PV 115D not powering

This forum is for discussions on all kinds of Peavey speakers and enclosures.
Post Reply
camarada78
New Member
Posts: 2
Joined: Thu Nov 12, 2020 3:10 pm

PV 115D not powering

Post by camarada78 » Thu Nov 12, 2020 3:50 pm

Hello,

I dont if you guys can help. I received a dead PV 115D to repair on my shop. It was a little worn but it was working before.

I have the schematics and I'm somewhat skilled in traditional amps but not so much in digital ones.

From the start I've changed the IR2153 and both IRFP460 because they'd be the usual suspects.

And so far i got these readings on the power supply:

+304vDC after the diode bridge (it is within specs of schematic) and on the drain of the first IRFP460. Seems ok.
+8.4vDC on pin 1 of the IR2153 IC. That is a little bellow specs (12vdc) with or without load.

Anyone experienced with this model?

camarada78
New Member
Posts: 2
Joined: Thu Nov 12, 2020 3:10 pm

Re: PV 115D not powering

Post by camarada78 » Sat Nov 14, 2020 9:14 am

I've managed to repair it (it was some circuit trails that were not working, had to put some wires).

But now i think the microphone volume is too low. It works fine with line leves, but its too low with microphone straight into the XLR

jim h
Member
Posts: 593
Joined: Fri Sep 12, 2008 11:20 pm

Re: PV 115D not powering

Post by jim h » Tue Nov 17, 2020 9:43 am

I would check ZD901 and ZD902 and the surrounding components.

Sometimes they fail shorted, sometimes they are just leaky.

Post Reply