kb300 cut off

This forum is for talking about Peavey keyboard amplifiers.
Post Reply
andomando
New Member
Posts: 3
Joined: Sun Mar 08, 2015 11:58 am

kb300 cut off

Post by andomando » Sat Feb 06, 2016 4:44 am

Hi everyone,I have a problem with my KB300 amp..it works well while jamming at home,i run a drum machine and my bass player plays through it ok for over two hours every three weeks.
But ?? when i have try to use it at a gig with my guitar, it only lasts for about five minutes then cuts off,with no sound,,lucky i carry another amp with me so i can use the peavey speaker with it.this has happened more than once.
Any help would be great.
regards


Andomando

RedRob
New Member
Posts: 3
Joined: Thu Nov 03, 2016 9:06 am

Re: kb300 cut off - KB100

Post by RedRob » Thu Nov 03, 2016 11:31 am

I have similar issue with my KB100.

I just opened the top and sprayed some contact cleaner into the POTS and inputs hoping it would help.

Plugged in my phone and it sounded great... for... maybe 20 minutes... then it cut out.

When it does cut out, the sound comes back on turn the power off/on quickly; in the past it also came back in with a pop when I plugged something into the "Patch Out/In" jack briefly.

Essentially -- this amp has been sitting idle for several years now because of this problem.. I'd love to put it back into use! Anyone have ideas on this?

RedRob
New Member
Posts: 3
Joined: Thu Nov 03, 2016 9:06 am

Re: kb300 / kb100 cut off

Post by RedRob » Thu Feb 22, 2018 6:36 pm

Does anyone read these? I still have an unusable (unreliable) but otherwise solid amp.

User avatar
Enzo
Member
Posts: 9089
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: kb300 cut off

Post by Enzo » Mon Jun 18, 2018 3:29 pm

Sorry Rob, you stuck yours on the end of someone else's and we never noticed it. I look every day.

Always best to start a new thread for your amp.

CHeck the solder on your patch jack and spray some cleaner into it, that is a strong clue.

Post Reply