Max 115 not working

This forum is for discussions on all kinds of Peavey bass amplifiers.
Post Reply
stha_y
New Member
Posts: 3
Joined: Sun Jul 18, 2021 10:16 am

Max 115 not working

Post by stha_y » Sun Jul 18, 2021 10:21 am

My peavy max 115 (300 watts) stopped working. When I turn on the amp, nothing comes up. I cannot use the tuner as well. Can anyone please tell me what the problem is and also guide me with the solution?

stha_y

User avatar
Enzo
Member
Posts: 9161
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: Max 115 not working

Post by Enzo » Tue Jul 20, 2021 10:03 am

Blown main fuse? And work from there

stha_y
New Member
Posts: 3
Joined: Sun Jul 18, 2021 10:16 am

Re: Max 115 not working

Post by stha_y » Fri Jul 23, 2021 11:08 am

Thanks, Enzo. Do you know where I can find the main fuse? It isn't next to the power supply unit. And I was not able to open the case. It looks like it is made up of a single wooden box. I cannot access the PCB inside.

stha_y

User avatar
Enzo
Member
Posts: 9161
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: Max 115 not working

Post by Enzo » Fri Jul 23, 2021 3:39 pm

Oh I am certain the amp chassis comes out of the wooden cab.

stha_y
New Member
Posts: 3
Joined: Sun Jul 18, 2021 10:16 am

Re: Max 115 not working

Post by stha_y » Mon Jul 26, 2021 11:39 am

Thanks. Do you know where I can find the service manual?

User avatar
Enzo
Member
Posts: 9161
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: Max 115 not working

Post by Enzo » Mon Jul 26, 2021 4:22 pm

Service manual is just the schematics and maybe a parts list. I only have the file for the older smaller unit. Not the 300 watt. You can drop a email to customer service at the factory and they might help.

I see fout screws into the top holding teh chassis in place. The two handle screws might also be involved. You probably have to remove teh grille to gain access.

Post Reply