SS Rage 158 Volume Pot

This forum is for talking about all kinds of Peavey guitar amplifiers.
Post Reply
schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

SS Rage 158 Volume Pot

Post by schnitzelhaus » Wed Sep 14, 2022 11:55 pm

I've googled as best I can, and can't find an answer. Does anyone know the correct value for a Silver Stripe Rage 158 Volume Pot?
I had a broken one that needed to be replaced, and I thought that 1M was correct. I soldered it in, and from 0 to 10, the the volume is unchanged.
Thanks for any insights!

User avatar
dak
Member
Posts: 155
Joined: Fri Dec 24, 2021 7:20 am
Location: Germany

Re: SS Rage 158 Volume Pot

Post by dak » Thu Sep 15, 2022 6:19 pm

My Google foo leads to https://www.audioservicemanuals.com/p/p ... -schematic which would put the volume pot at 10kOhms linear, something which I see a lot in solidstate Peavey amps. Also the pot's placement in the feedback path with ground on the wiper is quite typical for those amps.

User avatar
Pappy B
Member
Posts: 559
Joined: Sun Jan 31, 2016 2:30 pm

Re: SS Rage 158 Volume Pot

Post by Pappy B » Thu Sep 15, 2022 11:19 pm

I would think that 10K linear would be correct also. But the schematic I have looks like 1Meg logarithm.

I have to wonder if that is a misprint.
Attachments
RAGE_BLAZER_TRANSTUBE.pdf
(832.69 KiB) Downloaded 16 times
The more I learn the more I realize how much I don't know.

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Fri Sep 16, 2022 12:13 am

Thank you both; I'll try a 10K linear.

Pappy, we must've seen the same schematic.

User avatar
dak
Member
Posts: 155
Joined: Fri Dec 24, 2021 7:20 am
Location: Germany

Re: SS Rage 158 Volume Pot

Post by dak » Fri Sep 16, 2022 1:51 pm

Well, this is a different amp altogether. In your schematic, I read clean gain as 1.5M log, distortion pre-gain as 1.5M log and distortion post-gain as 10K linear. Lots of transistors, making it a transtube. My guess is that it isn't the same as an SS Rage 158. A photograph of the controls might give more of a clue which schematic might be relevant.

User avatar
Pappy B
Member
Posts: 559
Joined: Sun Jan 31, 2016 2:30 pm

Re: SS Rage 158 Volume Pot

Post by Pappy B » Fri Sep 16, 2022 5:07 pm

The schematic I sent is dated April 95 which should be about the time the Silver Stripe Transtube came out. But I have one earlier version that may help.
peaveyrage158.gif
peaveyrage158.gif (89.09 KiB) Viewed 136 times
The more I learn the more I realize how much I don't know.

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Sat Sep 17, 2022 1:15 am

dak wrote:
Fri Sep 16, 2022 1:51 pm
A photograph of the controls might give more of a clue which schematic might be relevant.
Here's the front, and both sides of the PCB. Thanks for your continued interest in this.
Attachments
IMG_4395.jpeg
IMG_4395.jpeg (1.23 MiB) Viewed 102 times
IMG_5222.jpeg
IMG_5222.jpeg (771.53 KiB) Viewed 102 times
IMG_4397.jpeg
IMG_4397.jpeg (990.9 KiB) Viewed 102 times

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Sun Sep 18, 2022 1:21 am

dak wrote:
Fri Sep 16, 2022 1:51 pm
A photograph of the controls might give more of a clue which schematic might be relevant.
I tried to post some pics yesterday, but I might be too new / not have enough posts. It's definitely a silver stripe transtube. The underside of the PCB has a few sets of numbers and words embedded in it, including "Copyright 1995."

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Tue Sep 20, 2022 11:16 pm

OK, I soldered in a 10K linear pot, and have the same results- when on the clean channel, the amp is a full volume, and turning the knob has no effect.
Not my first soldering job, and the joints look clean, but could that be an issue?

User avatar
dak
Member
Posts: 155
Joined: Fri Dec 24, 2021 7:20 am
Location: Germany

Re: SS Rage 158 Volume Pot

Post by dak » Thu Sep 22, 2022 4:58 pm

Ok, so clearly from the photographs it would be the schematics you posted that are relevant, so that would make it a 1M log pot. Sorry for the confusion. If C13 is shorted (part defect or solder bridge), that would explain your problem. You could try just removing it for a test: I may be mistaken but it seems mainly intended for quieting pot movement noise.

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Sun Sep 25, 2022 1:26 am

dak wrote:
Thu Sep 22, 2022 4:58 pm
Ok, so clearly from the photographs it would be the schematics you posted that are relevant, so that would make it a 1M log pot. Sorry for the confusion. If C13 is shorted (part defect or solder bridge), that would explain your problem. You could try just removing it for a test: I may be mistaken but it seems mainly intended for quieting pot movement noise.
Thanks, dak. I put the 1M log pot back in, and lifted one leg of C13. Pretty much the same story- Vol pot still doesn't do anything, but now, instead of being at full volume, it's at about 0.5. Does that tell us anything?
When I got started with this amp, it was fine except for a volume pot that was scratchy and cut out occasionally, and which wasn't cleared up with DeoxIT. That makes it seem to me that the problem must be directly related to something I did or didn't do.
I appreciate you sticking with me as I stumble through this.

User avatar
dak
Member
Posts: 155
Joined: Fri Dec 24, 2021 7:20 am
Location: Germany

Re: SS Rage 158 Volume Pot

Post by dak » Sun Sep 25, 2022 6:42 am

Does the post lead pot have any effect on the volume? If it is not properly separated via the lead/clean switch, the ability of the 1M pot to do anything would be quite compromised.

schnitzelhaus
New Member
Posts: 7
Joined: Wed Sep 14, 2022 11:43 pm

Re: SS Rage 158 Volume Pot

Post by schnitzelhaus » Mon Sep 26, 2022 12:26 am

dak wrote:
Sun Sep 25, 2022 6:42 am
Does the post lead pot have any effect on the volume?
Yes, when on the lead channel, both the pre and post affect the volume. Vol pot still has no effect.

User avatar
dak
Member
Posts: 155
Joined: Fri Dec 24, 2021 7:20 am
Location: Germany

Re: SS Rage 158 Volume Pot

Post by dak » Mon Sep 26, 2022 5:05 am

Sorry for being unclear. The question was whether the post lead pot affects the clean channel.

User avatar
Pappy B
Member
Posts: 559
Joined: Sun Jan 31, 2016 2:30 pm

Re: SS Rage 158 Volume Pot

Post by Pappy B » Mon Sep 26, 2022 1:44 pm

I believe DAK's question is key to the problem.

The Clean volume should not affect the Lead channel and the Pre and Post should not affect the Clean channel.

You should be able to set each channel to your liking then just switch back and forth between them.
The more I learn the more I realize how much I don't know.

Post Reply