Search found 247 matches

by rogue777
Sat Apr 17, 2021 7:23 pm
Forum: Guitar Amplifiers
Topic: Please help! Signal bleed at zero volume - Classic 30
Replies: 10
Views: 419

Re: Please help! Signal bleed at zero volume - Classic 30

That is strange. I would of thought all the tubes would be the same.

Make sure the tube socket is clean itself, and the PC bd area is clean (no contamination resulting in leakage).
All the tube socket connections should be electrically isolated from each other.
by rogue777
Thu Apr 15, 2021 9:46 am
Forum: Guitar Amplifiers
Topic: Please help! Signal bleed at zero volume - Classic 30
Replies: 10
Views: 419

Re: Please help! Signal bleed at zero volume - Classic 30

Not saying this will fix it,,,

I was wondering, focusing on the clean channel, does it make any difference if you swap tubes V1 with V2 and try it?
by rogue777
Tue Mar 30, 2021 10:40 pm
Forum: Guitar Amplifiers
Topic: valveking II 100 watt head schematic
Replies: 4
Views: 255

Re: valveking II 100 watt head schematic

Do you own a Valveking 100W II head? That seems like a rare amp. I own the VK 50W II combo and I think it’s really made well. The TSI circuitry is some slick stuff which involves a resettable fuse in the cathodes of each output tube, nicely done. Peavey make some nice products which lead the pack, i...
by rogue777
Tue Mar 30, 2021 7:07 pm
Forum: Guitar Amplifiers
Topic: valveking II 100 watt head schematic
Replies: 4
Views: 255

Re: valveking II 100 watt head schematic

I only remember the Valveking 20W II and 50W II combos. There's a manual on the internet that shows the Valveking 100W II head, and also a mini head. I was wrong about that. Your schematic is for the I-One edition as you see it doesn't have the TSI Tube Status Indicators in the circuit which the II ...
by rogue777
Mon Feb 15, 2021 7:26 pm
Forum: Guitar Amplifiers
Topic: Peavey VTX Classic troubleshooting help
Replies: 31
Views: 2149

Re: Peavey VTX Classic troubleshooting help

How did you get 183VAC (from center tap to each xformer end) and you only get 300VAC end to end. Shouldn't it be more like 366VAC? You made two measurements at the same test points using two ranges on your DVM. 183 VAC (200 ACV range) and 149 VAC (500 ACV range). Only one can be right. I think your ...
by rogue777
Sun Feb 14, 2021 7:39 pm
Forum: Vypyr & Sanpera
Topic: Vypyr 75 feedback problems ?.
Replies: 1
Views: 305

Re: Vypyr 75 feedback problems ?.

Sounds like you have too much signal output from the guitar with those pickups.
I wonder if you lower the guitar pickups alot, maybe it will help.
by rogue777
Tue Nov 03, 2020 10:10 am
Forum: Guitar Amplifiers
Topic: I need some help with mods I performed on a 6505 112?
Replies: 1
Views: 553

Re: I need some help with mods I performed on a 6505 112?

Great, sounds like your part changes had an effect, although the original parts maybe a better choice. If you use a scope and a sig gen, you could visually see the voltage gains and waveform distortion as you try different parts at different freqs.
by rogue777
Sat Oct 17, 2020 6:36 pm
Forum: Guitar Amplifiers
Topic: Artist 240 Transformers w/ tube preamp
Replies: 2
Views: 953

Re: Artist 240 Transformers w/ tube preamp

Ahh, A Peavey Artist 240. What a great amp. Those 4-6L6’s into one 4 ohm spk, that beast just roared, it’s a mean amp. I use to own one. Yes it’s a hybrid with the transistor preamp and Massive 6L6 pwr amp with 4 different input configurations. A Fender 5F6A Bassman, I have to admit thats a classic ...
by rogue777
Mon Sep 14, 2020 6:50 pm
Forum: Vypyr & Sanpera
Topic: Nano Vypyr showing low battery all the time
Replies: 2
Views: 918

Re: Nano Vypyr showing low battery all the time

Your batteries, Ni-MH or Nickel-metall hydride batteries are 1.2V batteries fully charged.
Alkaline D-Cell batteries are 1.5V batteries.

Looks like your using the wrong type of battery and the amp is working ok.
Its the difference in voltage thats causing it to shut down.
by rogue777
Wed Jun 03, 2020 3:18 pm
Forum: Guitar Amplifiers
Topic: Butcher MKII 120V switching issue
Replies: 7
Views: 2047

Re: Butcher MKII 120V switching issue

Are you sure the lights are LED's? They could be little lamps and the filaments are open. On one of the pictures - the back of the front panel bd has like little antenna leads sticking out. Those look like lamp leads. Also the voltage that makes it light could be an AC voltage. If they are lamps, wi...
by rogue777
Tue Jun 02, 2020 7:40 pm
Forum: Guitar Amplifiers
Topic: Butcher MKII 120V switching issue
Replies: 7
Views: 2047

Re: Butcher MKII 120V switching issue

Guitarman59, thanks for the reply. That’s good you have the two amps to compare them both. By selecting Master Volume 1 or 2 with the footswitch you are in effect controlling or programing the selected LED to light. Thanks for the pictures. If you can use a DVM and make voltage readings with the amp...
by rogue777
Mon Jun 01, 2020 8:00 pm
Forum: Guitar Amplifiers
Topic: Butcher MKII 120V switching issue
Replies: 7
Views: 2047

Re: Butcher MKII 120V switching issue

Is this the right manual? You guys must know more about this than I do. https://www.americanmusical.com/itemfiles/manual/pev_butcher100h_manual.pdf This manual implies the Master Volume 1 and 2 leds are controlled by the footswitch (which is a MIDI controller) or an external MIDI controller. You mus...
by rogue777
Sat May 30, 2020 11:17 am
Forum: Vypyr & Sanpera
Topic: Vypyr 75w help needed
Replies: 2
Views: 1100

Re: Vypyr 75w help needed

Your question was answered by James Paul in another post.
Page 4 shows the encoder table.
Page 1 shows the switches in circuit.

http://zorkmids.com/Download/EncoderBoard01.pdf
by rogue777
Tue Feb 04, 2020 10:34 pm
Forum: Vypyr & Sanpera
Topic: Peavey Vypyr 120 tube
Replies: 6
Views: 2714

Re: Peavey Vypyr 120 tube

bwQuestion, you did a great job figuring out which tube was bad! however you did it. Hopefully its only one bad tube. Glad you fixed it.
Although there could be other causes to blow F3, I think we can agree the Tubes would be the first to check.
by rogue777
Sat Feb 01, 2020 12:38 pm
Forum: Guitar Amplifiers
Topic: Missing 6505 parts (Front plate and logos) HELP
Replies: 2
Views: 1402

Re: Missing 6505 parts (Front plate and logos) HELP

I don't know how you can call it mint if its missing parts, whatever.

Is this what your looking for:

[urlhttps://www.ebay.com/sch/i.html?_from=R40&_trks ... o&_sacat=0][/url]

maybe a faceplate you can make your own,,