Search found 564 matches

by Pappy B
Thu Oct 06, 2022 7:30 pm
Forum: Guitar Amplifiers
Topic: No guitar sound from amp
Replies: 1
Views: 12

Re: No guitar sound from amp

If you haven't done so already, use some contact cleaner on all the jacks, switches, pots and connectors. You can also try using a a patch cord from pre-amp out to power amp in. If this helps it's a sure sign that it's time to do some cleaning.
by Pappy B
Fri Sep 30, 2022 8:01 pm
Forum: Guitar Amplifiers
Topic: SS Rage 158 Volume Pot
Replies: 32
Views: 429

Re: SS Rage 158 Volume Pot

Like DAK said, I think something is not right with the pot. I have bought pots 3 or 4 times in the last couple of years and twice I have gotten one that didn't work right when I received them. In both cases the wiper contacts were not not touching the track. I fixed both of them but I always wonder ...
by Pappy B
Fri Sep 30, 2022 3:38 pm
Forum: Guitar Amplifiers
Topic: Peavey Solo Series Bandit (early 80's)
Replies: 10
Views: 106

Re: Peavey Solo Series Bandit (early 80's)

Over the years quite a bit of debris can build up in the voice coil gap. Some of the Scorpions had a layer foam built into the vent hole in the magnet. It crumbles and some of it ends up in the groove and the voice coil moving back and forth compacts it and restricts coil/cone movement. Even if it d...
by Pappy B
Fri Sep 30, 2022 11:15 am
Forum: Guitar Amplifiers
Topic: SS Rage 158 Volume Pot
Replies: 32
Views: 429

Re: SS Rage 158 Volume Pot

Finally got a chance to look at the schematic again. Have you checked capacitor C13 to see if it is shorted? It is right next to the channel switch, It looks like a resistor with a green body but it is really a cap. If you don't have a multimeter you can just lift one leg out of the board and see if...
by Pappy B
Thu Sep 29, 2022 9:38 am
Forum: Guitar Amplifiers
Topic: Studio Pro 50 Board/Component Layout Diagram?
Replies: 3
Views: 67

Re: Studio Pro 50 Board/Component Layout Diagram?

That amp is old enough that some of the electrolytic capacitors may be leaking. The small 2.2 uF are usually the 1st to go. The problem with old caps is that they may look fine buy they aren't.
by Pappy B
Mon Sep 26, 2022 1:44 pm
Forum: Guitar Amplifiers
Topic: SS Rage 158 Volume Pot
Replies: 32
Views: 429

Re: SS Rage 158 Volume Pot

I believe DAK's question is key to the problem.

The Clean volume should not affect the Lead channel and the Pre and Post should not affect the Clean channel.

You should be able to set each channel to your liking then just switch back and forth between them.
by Pappy B
Sun Sep 25, 2022 12:33 am
Forum: Guitar Amplifiers
Topic: Peavey Solo Series Bandit (early 80's)
Replies: 10
Views: 106

Re: Peavey Solo Series Bandit (early 80's)

Something else you can do in the mean time is pull the magnet off of the Scorpion and clean the voice coil groove. There are some videos on you tube.

I've had 2 over the years that sounded bad when I got them but was surprised how much better they sounded after cleaning them.
by Pappy B
Fri Sep 23, 2022 5:04 pm
Forum: Guitar Amplifiers
Topic: Peavey Solo Series Bandit (early 80's)
Replies: 10
Views: 106

Re: Peavey Solo Series Bandit (early 80's)

Previous to the Transtube series all Bandits where Solo series and almost all of them made in the 80's. Out of curiosity which one do you have? If this is a relatively new amp to you, get to know it pretty well before replacing a speaker. If it has any problems address them 1st. Knowing what tone co...
by Pappy B
Sat Sep 17, 2022 11:52 am
Forum: Guitar Amplifiers
Topic: Pacer 100 hum
Replies: 18
Views: 6502

Re: Pacer 100 hum

I spent yesterday afternoon doing some maintenance on my Pacer. Couple of the 10K pots where getting noisy and erratic. I actually pulled almost all of the pots off of the board and opened them up. Cleaned a lot of old sticky dark grease out of most of them. I think spraying them through the small o...
by Pappy B
Fri Sep 16, 2022 5:07 pm
Forum: Guitar Amplifiers
Topic: SS Rage 158 Volume Pot
Replies: 32
Views: 429

Re: SS Rage 158 Volume Pot

The schematic I sent is dated April 95 which should be about the time the Silver Stripe Transtube came out. But I have one earlier version that may help.
peaveyrage158.gif
peaveyrage158.gif (89.09 KiB) Viewed 241 times
by Pappy B
Fri Sep 16, 2022 9:14 am
Forum: Guitar Amplifiers
Topic: Neutral to ground bypass capacitor
Replies: 4
Views: 112

Re: Neutral to ground bypass capacitor

If you go to "justradios.com" they have a lot of information on capacitors including Y and X capacitors.
by Pappy B
Thu Sep 15, 2022 11:19 pm
Forum: Guitar Amplifiers
Topic: SS Rage 158 Volume Pot
Replies: 32
Views: 429

Re: SS Rage 158 Volume Pot

I would think that 10K linear would be correct also. But the schematic I have looks like 1Meg logarithm.

I have to wonder if that is a misprint.
by Pappy B
Mon Sep 12, 2022 8:28 pm
Forum: Guitar Amplifiers
Topic: Peavey ED-100 Output Volume Cuts In Half
Replies: 2
Views: 53

Re: Peavey ED-100 Output Volume Cuts In Half

Could be a thermal problem. If you pull the chassis and do the cleaning that James \Paul suggests look for signs of heat discoloration. Look for bulges on the ends of electrolytic caps and look for resistors that look like they got too hot.
by Pappy B
Mon Sep 12, 2022 12:48 pm
Forum: Speakers/Enclosures
Topic: 1977 412S speaker cabinet
Replies: 3
Views: 285

Re: 1977 412S speaker cabinet

My old Peavey speaker list says they had 121638G speakers in them. And I too would expect them to be Eminence, but possibly CTS.
by Pappy B
Sun Sep 11, 2022 11:06 am
Forum: Guitar Amplifiers
Topic: classic 20 channel 2 not working right
Replies: 8
Views: 166

Re: classic 20 channel 2 not working right

If you have access to another amp, run your pre-amp out to the other power-amp in then the other amp's pre-amp to your power-amp in. Should be able to determine if the problem is in the pre-amp or power-amp section.